SQL Server 2008 R2 – Intellisense not working – Visual Studio 2010 SP 1

Hi,

Recently intellisense in the SQL Server management Studio stopped working.

It appears that it was caused by the installation of Visual Studio 2010 SP1.

The issue was raised here:
https://connect.microsoft.com/SQLServer/feedback/details/650569/ssms-2008-r2-is-losing-intellisense-after-installing-visual-studio-2010-sp1

It was originally suggested that this could fixed by SQL Server 2008 R2 Cumulative Update #6, but this in turn lead to a crash in Visual Studio 2010 when ever you opened a .sql file in your database projects.
https://connect.microsoft.com/VisualStudio/feedback/details/653180/method-not-found-opening-files-in-database-project

It suggested that this issue has been fixed and will be released in SQL Server 2008 R2 Cumulative Update #7, which was due out in Mid April.

You can install Cumulative Update #6 and in most cases this will get intellisense working in SSMS but it will break Intellisense (on database projects) in VS2010.

So if you are like me, you are between a rock and a hard place, your choice of which environment you prefer to have working.

Lets hope that CU #7 fixes it.

I will update this post with my results after I have applied CU #7.

Cheers…

Update as @ 19th April

Today Microsoft has released Cumulative Update package 7 for SQL Server 2008 R2

After downloading and installing, preliminary results are that the problem is solved.

Intellisense in SSMS seems to be working and I no longer get the crashes in Visual Studio 2010 and Intellisense in Visual Studio 2010 database projects also seem to be working correctly. So, so far so good.

Update as of Nov 2011

As someone has pointed out the release of SQL Server 2008 R2 SP1 is supposed to fix this issue, (as it contains all the rolled up cumulative updates).

I personally have had mixed results with some machines working again and others having “Intellisense” working in SQL management Studio but remaining broken in Visual Studio 2010. My main work Development environment is still broken in this way and if I ever get it working I will udpate you on what I had to do, but for now I am living with only having intellisense in the SQL management studio.

11 thoughts on “SQL Server 2008 R2 – Intellisense not working – Visual Studio 2010 SP 1

    1. The above note as @ 19th April was tested on a 32-bit windows 7 box with SQL Express 2008 R2 (Advanced Install). It upgraded fine.

      I went to work and tried it out and no luck. Work is a 64-bit Windows Server 2008 R2 box. I applied the 32-bit update. No luck.

      I tried to apply the 64-bit update but the package complained about being the first in a set. I applied the 64-bit update today after waiting for microsoft to fix it. Still no luck.

      I re-applied VS 2010 SP1 and rebooted and Intellisense in SQL Server is now working again, but the VS 2010 appears not to be working still.

    1. I used the following:
      Windows 32 bit – SQLServer2008R2_RTM_CU7_2507770_10_50_1777_x86
      Windows 64 bit – SQLServer2008R2_RTM_CU7_2507770_10_50_1777_x64

      Cheers

  1. I downloaded SQLServer2008R2_RTM_CU7_2507770_10_50_1777_x64.

    When extracting I tried with the 2 passwords given by hotfix. But it is not extracting. What is the problem please mail me

    1. I assume you are on a 64-bit server? I had issues with this download @ first complaining about it needing the first in the backup set, but after a week I tried downloading again and it worked fine. If you are on a 32 bit machine you should download “SQLServer2008R2_RTM_CU7_2507770_10_50_1777_x86”. Beyond that you may need to try it on another machine or follow it up with microsoft.

    1. Yes, sorry. Wrote this post a while ago. When SQL Server SP 1 came out, I quickly installed it on all of my SQL Server 2008 R2 development boxes that were having this issue (x 3). In 2 cases intellisense now works and all is right with the world. In one case the environment is still broken. I get Intellisense in SQL Server 2008 R2 but Intellisense is still broken in Visual Studio 2010, (every now and then for a few minutes it starts working and then stops)

      Given Visual Stuido 11 is out in beta, and SQL Server 20012 is now out in RTM so perhaps this issue will just blend into the background as people adopt the newer environments.

Leave a Reply to Jitendra Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.